WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)


Forum: Installation und Update (Windows 7)

Windows Installationsprobleme, Fragen zur Neuinstallation und Upgradeinstallation von Windows 7

Schlagworte:
  1. thl1966

    thl1966 Aktives Mitglied

    Möchte hier mal einen Thread eröffnen, weil das Thema nie so groß behandelt wird. Es geht um die Windows Automated Installation Kit (WAIK), eine kostenlose Zusatzsoftware für Windows 7, dass es mittlerweilen als Release Kandidat gibt. Wer hat schon Erfahrungen bzw. Anleitungen zu bestimmten Vorgehensweisen z.B. Erstellung einer Slipstream DVD / Einbindung mit Treibern / Servicepacks / Tweaks /Notfall Start DVD mit Tools etc.
    Mal gespannt, was so alles kommt. Werde mich demnächst intensiv damit beschäftigen und hier dann meine Anleitungen posten.
     
  2. Werbung
  3. michael

    michael Beta Tester

    WAIK unter Windows 7 - Installation

    So, ich fange mal mit der Installation an, die wirklich kein Hexenwerk ist.

    1. Download der finalen Version unter: http://www.microsoft.com/downloads/...65-9f76-4177-a811-39c26d3b3b34&displaylang=de

    Dateiname: KB3AIK_DE.iso
    Dateigröße: 1,58 GB

    2. ISO-Datei auf DVD brennen und CDstart.exe ausführen.

    3. Windows-AIK Setup anklicken und die Installationsschritte durchklicken (siehe Anhänge)

    Als nächstes werde ich mir mal die Dokumentation durchlesen (Startmenü -> Microsoft Windows AIK -> Dokumentation)
     

    Anhänge:

    • waik1.jpg
      waik1.jpg
      Dateigröße:
      84,2 KB
      Aufrufe:
      489
    • waik2.jpg
      waik2.jpg
      Dateigröße:
      39,2 KB
      Aufrufe:
      347
    • waik3.jpg
      waik3.jpg
      Dateigröße:
      99,4 KB
      Aufrufe:
      330
    • waik4.jpg
      waik4.jpg
      Dateigröße:
      68,3 KB
      Aufrufe:
      342
    • waik5.jpg
      waik5.jpg
      Dateigröße:
      40,8 KB
      Aufrufe:
      322
    • waik6.jpg
      waik6.jpg
      Dateigröße:
      42,6 KB
      Aufrufe:
      318
    • waik7.jpg
      waik7.jpg
      Dateigröße:
      39,9 KB
      Aufrufe:
      349
  4. thl1966

    thl1966 Aktives Mitglied

    AW: WAIK unter Windows 7 - Installation

    Wollte auch mal den Anfang machen, was man beachten sollte, bei der Erstellung einer Automatischen Installation unter Windows 7.
    Nach der Installation auf jeden Fall die Dokumentation lesen!! nur durch rumprobieren bekommt man es definitiv nicht hin.
    Es gibt 5 Phasen für die erfolgreiche Implementierung einer Automatischen Installation:
    Diese wären:

    Phase 1: Planung der Bereitstellung
    Phase 2: Erstellung der Bereitsstellungsumgebung
    Phase 3: Vorbereiten und Anpassung des Windows-Abbilds
    Phase 4: Bereitsstellen des Windows Abbilds
    Phase 5: Verwalten und warten des Windows-Abbilds

    Phase 1: hier sollte man sich schon überlegen, wie am Ende die Infrastruktur aussehen, die abgebildet werden soll. Welche Treiber und Anwendungen bereitsgestellt werden soll

    Phase 2: Hier wird der Referenz-PC erstellt, das Netzwerk konfiguriert und dann ein Windows PE-Abbild erstellt

    Phase 3: Hier wird die Antwortdatei für eine umbeaufsichtigte Installation erstellt/konfiguriert

    Phase 4: Hier wird das Windows-Abbild mit dem Windows-Setup oder ImageX erstellt

    Phase 5: Zusatzarbeiten: wie Einbindung von Language Packs, Gerätetreiber, Updates mit dem Tool DISM - Depolyment Image Servicing and Management

    Werde mich die nächsten Wochen intensiv einlesen und sobald ich eine Unattend DVD/BlueRay erfolgreich erstellt worden ist, werde ich eine Schritt-für-Schritt-Anleitung erstellen und hier einstellen.
     
  5. thl1966

    thl1966 Aktives Mitglied

    AW: WAIK unter Windows 7 - Installation

    Hier mal eine Antwortdatei als Beispiel "Autounattend.xml"
    sollte sich jeder selbst anpassen

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <servicing>
    <package action="configure">
    <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.0.6000.16386" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />
    <selection name="TabletPCOC" state="true" />
    <selection name="TelnetClient" state="false" />
    <selection name="TelnetServer" state="false" />
    <selection name="Windows-Ultimate-Extras" state="true" />
    <selection name="AxInstallService" state="false" />
    <selection name="FaxServicesUltimate" state="true" />
    <selection name="IIS-WebServerRole" state="false" />
    <selection name="InboxGames" state="true" />
    <selection name="Indexing-Service-Package" state="false" />
    <selection name="Microsoft-Windows-RemovableStorageManagement" state="false" />
    <selection name="XPS-Viewer" state="true" />
    <selection name="Printing-Foundation-Features" state="true" />
    <selection name="SUA" state="false" />
    <selection name="NetFx3" state="true" />
    </package>
    </servicing>
    <settings pass="specialize">
    <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Help_Page>http://www.google.com</Help_Page>
    <Home_Page>about:blank</Home_Page>
    <FilterLevel>Medium</FilterLevel>
    <BlockPopups>yes</BlockPopups>
    <ShowInformationBar>true</ShowInformationBar>
    <FavoritesDelete>false</FavoritesDelete>
    <IEWelcomeMsg>true</IEWelcomeMsg>
    <PlaySound>true</PlaySound>
    </component>
    <component name="Microsoft-Windows-ehome-reg-inf" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DisableExpressSetup>false</DisableExpressSetup>
    </component>
    <component name="Microsoft-Windows-RemoteAssistance-Exe" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <fAllowToGetHelp>false</fAllowToGetHelp>
    </component>
    <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SkipAutoActivation>true</SkipAutoActivation>
    </component>
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <AutoLogon>
    <Username>Administrator</Username>
    <Enabled>true</Enabled>
    <LogonCount>2</LogonCount>
    </AutoLogon>
    <BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
    <Display>
    <ColorDepth>32</ColorDepth>
    <DPI>120</DPI>
    <HorizontalResolution>1024</HorizontalResolution>
    <RefreshRate>75</RefreshRate>
    <VerticalResolution>768</VerticalResolution>
    </Display>
    <Themes>
    <DefaultThemesOff>false</DefaultThemesOff>
    </Themes>
    <WindowsFeatures>
    <ShowInternetExplorer>true</ShowInternetExplorer>
    <ShowMediaCenter>true</ShowMediaCenter>
    <ShowWindowsMail>true</ShowWindowsMail>
    <ShowWindowsMediaPlayer>true</ShowWindowsMediaPlayer>
    </WindowsFeatures>
    <RegisteredOwner>0wner</RegisteredOwner>
    <RegisteredOrganization>0wn Inc.</RegisteredOrganization>
    <DoNotCleanTaskBar>false</DoNotCleanTaskBar>
    <StartPanelOff>false</StartPanelOff>
    <ShowWindowsLive>true</ShowWindowsLive>
    <CopyProfile>true</CopyProfile>
    <ComputerName>Computer</ComputerName>
    <TimeZone>India Standard Time</TimeZone>
    </component>
    <component name="Microsoft-Windows-SQMApi" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <CEIPEnabled>0</CEIPEnabled>
    </component>
    <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DisableSR>1</DisableSR>
    </component>
    <component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <fDenyTSConnections>true</fDenyTSConnections>
    </component>
    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Identification>
    <JoinWorkgroup>LAN</JoinWorkgroup>
    </Identification>
    </component>
    <component name="Security-Malware-Windows-Defender" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DisableAntiSpyware>false</DisableAntiSpyware>
    </component>
    <component name="Networking-MPSSVC-Svc" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <FirewallGroups />
    <DomainProfile_EnableFirewall>true</DomainProfile_EnableFirewall>
    <PrivateProfile_EnableFirewall>true</PrivateProfile_EnableFirewall>
    <PublicProfile_EnableFirewall>true</PublicProfile_EnableFirewall>
    <PrivateProfile_DisableNotifications>false</PrivateProfile_DisableNotifications>
    </component>
    </settings>
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-ehome-reg-inf" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <WorkOffline>false</WorkOffline>
    </component>
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <OEMInformation>
    <Logo>%SystemRoot%\120x120x32.bmp</Logo>
    <Manufacturer>Alienware</Manufacturer>
    <Model>top-of-the-line model</Model>
    <SupportURL>http://www.google.com</SupportURL>
    </OEMInformation>
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <NetworkLocation>Home</NetworkLocation>
    <ProtectYourPC>3</ProtectYourPC>
    <SkipMachineOOBE>true</SkipMachineOOBE>
    <SkipUserOOBE>true</SkipUserOOBE>
    </OOBE>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action="add">
    <Password>
    <Value>QueCera</Value>
    <PlainText>true</PlainText>
    </Password>
    <Description>the PC doctor!</Description>
    <DisplayName>Vaidh</DisplayName>
    <Group>Administrators</Group>
    <Name>Vaidh</Name>
    </LocalAccount>
    <LocalAccount wcm:action="add">
    <Description>everyday use</Description>
    <DisplayName>Normal Usage</DisplayName>
    <Group>Users</Group>
    <Name>Normal Usage</Name>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    <VisualEffects>
    <FontSmoothing>Standard</FontSmoothing>
    </VisualEffects>
    <FirstLogonCommands>
    <SynchronousCommand wcm:action="add">
    <CommandLine>%SystemDrive%\install\GUIrunOnce.cmd</CommandLine>
    <Description>customises settings</Description>
    <Order>20</Order>
    </SynchronousCommand>
    </FirstLogonCommands>
    </component>
    <component name="Microsoft-Windows-Sidebar" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SidebarOnByDefault>false</SidebarOnByDefault>
    <SidebarVisible>false</SidebarVisible>
    </component>
    <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <InputLocale>0409:00000409</InputLocale>
    <SystemLocale>en-us</SystemLocale>
    <UILanguage>en-us</UILanguage>
    <UserLocale>en-US</UserLocale>
    <UILanguageFallback>en-US</UILanguageFallback>
    </component>
    </settings>
    <settings pass="auditSystem">
    <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DriverPaths>
    <PathAndCredentials wcm:keyValue="cd7c395" wcm:action="add">
    <Path>%SystemRoot%\PnPdrvrs</Path>
    </PathAndCredentials>
    </DriverPaths>
    </component>
    </settings>
    <settings pass="generalize">
    <component name="Microsoft-Windows-Security-Licensing-SLC" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SkipRearm>0</SkipRearm>
    </component>
    <component name="Microsoft-Windows-SharedAccess" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <EnableICS>false</EnableICS>
    </component>
    </settings>
    <settings pass="windowsPE">
    <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Diagnostics>
    <OptIn>false</OptIn>
    </Diagnostics>
    <DiskConfiguration>
    <WillShowUI>Always</WillShowUI>
    </DiskConfiguration>
    <DynamicUpdate>
    <Enable>false</Enable>
    </DynamicUpdate>
    <UserData>
    <ProductKey>
    <WillShowUI>Never</WillShowUI>
    <Key>REMOVED</Key>
    </ProductKey>
    <AcceptEula>true</AcceptEula>
    <FullName>0wner</FullName>
    <Organization>0wn Inc.</Organization>
    </UserData>
    <ComplianceCheck>
    <DisplayReport>Never</DisplayReport>
    </ComplianceCheck>
    <LogPath>%SystemRoot%\temp</LogPath>
    <UseConfigurationSet>true</UseConfigurationSet>
    <ImageInstall>
    <OSImage>
    <InstallFrom>
    <MetaData wcm:action="add">
    <Value>Windows Vista ULTIMATE</Value>
    <Key>1</Key>
    </MetaData>
    </InstallFrom>
    <WillShowUI>OnError</WillShowUI>
    </OSImage>
    </ImageInstall>
    </component>
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    <WillShowUI>Never</WillShowUI>
    </SetupUILanguage>
    <InputLocale>en-US</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UILanguageFallback>en-US</UILanguageFallback>
    <UserLocale>en-US</UserLocale>
    </component>
    </settings>
    <settings pass="auditUser">
    <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Description>command1</Description>
    <Order>10</Order>
    <Path>cmd /C %SystemDrive%\install\one.cmd</Path>
    </RunSynchronousCommand>
    <RunSynchronousCommand wcm:action="add">
    <Description>command2</Description>
    <Order>20</Order>
    <Path>cmd /C %SystemDrive%\install\cmdlines.cmd</Path>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    </settings>
    <cpifflineImage cpi:source="wim:k:/sources/install.wim#Windows Vista ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
     
  6. michael

    michael Beta Tester

    AW: WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)

    Bist du schon weiter gekommen? Ich hatte bisher absolut keine Zeit mich tiefer reinzuhängen. Am WE muss ich komplett arbeiten ... Mist!
     
  7. thl1966

    thl1966 Aktives Mitglied

    AW: WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)

    Hallo Michael,

    habe mal ein wenig ausprobiert und ein Languagepack in die Windows 7 Installations DVD eingebunden. Habe da noch ein paar kleine Probleme, die ich aber bestimmt in den Griff bekomme. Sobald ich was funktionierendes erstellt habe, werde ich hier weiter posten zu dem Thema. Das WAIK-Kit ist super interessant, was man da alles machen kann. Aber man muss erst viel Dokumentation lesen, bevor man überhaupt mal anfangen kann.
     
  8. thl1966

    thl1966 Aktives Mitglied

    AW: WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)

    Habe hier eine Seite gefunden, wo ziemlich genau erklärt wird, wie man eine Antwortdatei für das Betriebssystem mit dem WAIK Kit generiert (Unbeaufsichtigte Installation). Dies ist fast identisch mit Windows 7. Sehr interessanter Artikel.
    http://www.winpage.info/pages/Vista/unattend.php
     
  9. Aeroholic

    Aeroholic Neuling

    AW: WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)

    Moin Moin, ich bin auch gerade dabei mich mit dem Thema zu beschäftigen ;-)
    @thl966 ich weiß es ist ein alter Thread, aber ich wollte mal fragen ob du die "Schritt-für-Schritt-Anleitung" schon geschrieben hast!?!?!?!

    Viele Grüße
     
  10. thl1966

    thl1966 Aktives Mitglied

    AW: WAIK unter Windows 7 verwenden (Slipstream, Treibereinbindung etc.)

    Ja, habe ich mal angefangen, aber nicht fertig gestellt, da ich noch andere wichtige Dinge zu erledigen habe. Werde ich wohl spätestens mit SP2 mal wieder angehen.
     
  • Werbung
  • Die Seite wird geladen...
    Hier genannte Produkt- und Firmennamen sowie deren Logos koennen eingetragene Warenzeichen der jeweiligen Unternehmen sein.