Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung


Forum: Allgemeine Fragen und Probleme (Windows 7)

Alle Windows 7 Themen, die nicht in die anderen Foren passen.

  1. fantafear

    fantafear Neuling

    Hallo!

    Seit ich auf Windows 7 umgestiegen bin, habe ich folgendes problem:

    Ich möchte mit 3 kernen rendern, und einen für windows reservieren, um noch normal nebenher arbeiten zu können (zb internet surfen od. skypen).

    Bei windows xp war das überhaupt kein problem. 3 cpus haben vollgas gerechnet (100% cpu last), die vierte cpu hat sich fadisiert und ich konnte wunderbar flüssig im windows arbeiten.

    Nicht so bei windows 7: Sogar wenn ich drei (!) von vier cpus für windows reserviere und nur EINE cpu der anwendung zuweise, ruckelt es sehr stark wenn man im windows irgendwas anklickt. Nicht mal fensteranimationen werden ruckelfrei animiert. Anwendungen starten dauert ewig, beim schreiben lagt es, usw. Es fühlt sich einfach an wie mit einer 1-kern-maschine wo die cpu durch die render-software gnadenlos durchgenommen wird und die diversen windows tasks einfach hinten an stehen und nicht dran kommen.

    Genauso wenig wie die Zugehörigkeits-auswahl zeigt die Prioritäts-Vergabe wirkung! Ich kann den maya-batch prozess sogar auf "Idle" stellen, und trotzdem lahmt das system noch gewaltig, obwohl der prozess sofort "nachgeben" müsste, wenn man nun ein anderes programm in den fokus nimmt.

    Ach ja, ich bin 3d-grafiker und rendere mit autodesk maya x64. Die software belagert, je nach scene-größe, ca. 2,5GB ram und beim batch-rendern sind ca. 85% speicher von insgs. 4gb voll ! War aber beim xp auch so, das ist okay so.

    Hat jemand ne idee an was das liegen könnte?
    Software/treiber updates meiner hardware habe ich schon versucht, war leider teilweise erfolglos, da die ganzen treiber-installer nicht für x64 funktionieren. Im gerätemanager sieht alles sauber aus. Keine bösen rufzeichen, etc.

    Mein System:

    Win7 ultimate x64
    Core2 Quad Q6600 2.4GHz
    Socket 775 LGA
    ASUS P5K Premium Intel P35 ICH9R
    Corsair-6400 400MHZ DDR2 4GB
    Nvidia GeForce GTX 260 896MB
    WD Raptor X 150GB 10000rpm


    Wäre ultra dankbar für irgendwelche tipps, denn ich hab echt keine idee an was das liegen könnte. Google hilfe ergab auch keine brauchbaren suchergebnisse :(.

    lg & vielen dank,
    ff
     
  2. Werbung
  3. thl1966

    thl1966 Aktives Mitglied

    AW: Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung

    Wie reservierst du die einzelnen CPUs?
    Welche Prioritäten hast du den Tasks zugeordnet?
     
  4. fantafear

    fantafear Neuling

    AW: Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung

    ich rechtsklicke im windows task-manager auf maya.exe und geh auf "zugehörigkeit festlegen..." und dort wähle ich 3 von 4 cpus aus.

    jene cpu die nicht ausgewählt wird, bleibt nun für andere anwendungen reserviert und wird von maya nicht beansprucht.


    das selbe mit der priority: rechtsklick auf maya.exe => priorität festlegen => niedrig.

    sobald nun ein leistungshungrigeres programm sich breit macht, schaltet maya nun einen gang zurück.


    tja, so sollts zumindest in der theorie funktionieren, bzw. hat es so im windows xp perfekt funktioniert.
     
  5. thl1966

    thl1966 Aktives Mitglied

    AW: Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung

    Vieleicht liegt es am 64-Bit System, dass es da noch nicht richtig funktioniert bzw. die Prozesszuordnung anders gehandelt wird, was ich mir aber nicht vorstellen kann. Muss das heute Abend mal mit meinem Quadcore Prozessor an meinem Notebook ausprobieren. Habe auch 64-Bit Windows 7 Ultimate installiert. Ich berichte dann, ob es geht. Vieleicht liegt es an deiner Anwendung, dass es die Prozesszuordnung bei 64-Bit nicht richtig verarbeiten kann.
     
  6. fantafear

    fantafear Neuling

    AW: Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung

    ich habe es eben mit maya 2008 x64 und maya 2010 x64 versucht. leider bei beiden programmen das selbe problem.

    weiters habe ich versucht den effekt mit premiere CS5 zu reproduzieren. ist aber leider nicht möglich, da premiere selbst beim encoding in h264 alle 4 cpus nicht so auslastet, wie maya beim rendern.

    wenn ich das problem bis heute nacht nicht lösen kann, kommt wieder xp x64 rauf. was für ein jammer.

    ein kumpel von mir arbeitet auch mit win7 ultimate x64, maya 2008 x64 und einer 4-kern maschine, und bei ihm klappt das mit der zugehörigkeits-vergabe wunderbar.
    darum tippe ich, dass bei mir irgendwas mit dem chipsatztreiber für win7 faul ist.
     
  7. thl1966

    thl1966 Aktives Mitglied

    AW: Prozess Zugehörigkeits-Auswahl zeigt keine Wirkung

    Könnte sein, dass es am Chipsatztreiber liegt. Wenn du das Problem gefunden hast, würde mich die Lösung interessieren. Habe es übrigends gestern bei mir ausprobiert und die Verteilung der CPU/Prozesse geht einwandfrei. Habe selbst Windows 7 64-Bit Ultimate.
     
  • Werbung
  • Die Seite wird geladen...
    Hier genannte Produkt- und Firmennamen sowie deren Logos koennen eingetragene Warenzeichen der jeweiligen Unternehmen sein.