Deaktivierte Dienste lassen sich unter Windows 7 nicht mehr aktivieren


Forum: Allgemeine Fragen und Probleme (Windows 7)

Alle Windows 7 Themen, die nicht in die anderen Foren passen.

  1. homezonebenny

    homezonebenny Mitglied

    Wie der Titel schon treffend beschreibt kann ich deaktivierte Dienste nicht "aktivieren".


    Versuch 1:
    win + r -> msconfig -> Reiter "Dienste"

    Wenn ich hier die haken bei den Diensten setze und anschließend auf ÜBERNEHMEN klicke so entfernt es automatisch wieder die haken bei den Diensten die deakt. sind. Wenn ich alle haken entferne, und übernehme bleiben diese weg. Wenn ich wieder alle haken setze, so übernimmt er alle aber einige haken springen automatisch sofort wieder hinaus. Nämlich diese Dienste die momentan deakt. sind und sich auch nicht aktivieren lassen. Hierzu ein paar Bilder um welche Dienste es sich hierbei handelt.

    siehe Dienste ohne haken:

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]


    Versuch 2:
    Direkt über die Dienste:
    Windows Taste - Dienste (tippen) ENTER

    Nun befindet man sich direkt im Dienste Fenster wo man die Starttypen etc. festlegen kann. Hier habe ich versucht die Dienste zu starten bzw. ihren Starttyp auf automatisch zu legen. Nur leider sind die Menüpunkte bei Rechtsklick auf den entsprechenden Dienst transparent (nicht anklickbar). Über EIGENSCHAFTEN kann ich zwar den Starttyp auf "automatisch" stellen, aber sobald ich "Übernehmen" oder "Ok" drücke kommt folgende Fehlermeldung:
    "Das System kann den angegebenen Pfad nicht finden."

    Hierzu auch Bilder (als Beispiel hierzu der Windows Defender):
    [​IMG]

    [​IMG]

    Dieses Problem lässt sich auf alle Diensten der ersten 7 Bilder reproduzieren.
    Die können nicht gestartet werden und ihr Starttyp lässt sich dank der Fehlermeldung nicht verändern. Es handelt sich hierbei also nicht nur um den Windows Defender der durch irgendeine "Software" deaktiviert wurde. Ich benutze als AntiVirenSoftware einzig und allein Avira - Free Editon. Also kann ich (ausgenommen des Echtzeitschutzes) eigentlich den Defender voll aktiviert lassen. Wie gesagt, es lässt sich auf alle Dienste reproduzieren die in den Shoots vorkommen. Andere Dienste kann ich deaktivieren, und auch wieder aktivieren.


    Ich hoffe ich konnte mein Problem gut genug darstellen so das keine Fragen hierzu offen bleiben, sollten dennoch Fragen auftreten so bitte ich diese zu stellen.
    Gleichzeitig möchte ich mich für eure Hilfe bedanken.


    PS: Die svchost.exe ist vorhanden, habe ich schon überprüft. Evt. ist diese deffekt oder korrumpiert oder sonstiges... aber das kann ich nicht sagen, Virenüberprüfung ergab keine Fehler. CHDSK habe ich durchlaufen lassen auch nichts, wobei das weniger mit den Diensten zu tun hat, dass ist klar.
     
  2. Werbung
  3. michael

    michael Beta Tester

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Hast du dich mal mit dem Benutzer "Administrator" angemeldet und versucht? Benutzerkontensteuerung mal deaktiviert? Vieleicht fehlen dir Berechtigungen.
     
  4. homezonebenny

    homezonebenny Mitglied

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Glaube nicht das das Problem so banal ist. 1. habe ich eigentlich volle Zugriffsrechte bzw. kann mir diese geben, daran liegt es eig. nicht. Ich werde aber mal die Benutzerkontensteuerung beenden und schauen ob sich was tut, ich denke das es aber nicht helfen wird.

    Eine kleine Zusatzinformation:
    Diese Problem trat erst auf als ich meinen PC hochfuhr und auf einmal das Design im Windows 95 look erschien. Ich hab dann versucht dieses umzustellen doch ging das nicht weil nicht vorhanden. STRG + SHIFT + ESC und ich sah 16 Prozesse. Dies verwunderte mich also WIN + R -> msconfig und bei Dienste geschaut, alle haken waren entfernt. Also habe ich alle haken setzen lassen auf OK gedrückt und dann neugestartet und alles war wieder wie gewohnt. Tage später erst habe ich festgestellt das der Defender gar nicht läuft, als ich diesen starten wollte ging es eben nicht (siehe Liste oben). Als ich es bei anderen deaktivierten Diensten versuchte das gleiche Problem. Es geht hierbei nun auch nicht um den Defender an sich, sondern um die Dienstliste oben. Die Dienste ohne haken können nicht gestartet werden bzw. der Starttyp lässt sich nicht verändern. Fehlermeldung ist die oben genannte.

    Wenn jemand Rat weiß woher diese Fehlermeldung stammt bzw. wie man das Problem lösen kann, bitte Melden :)
     
  5. michael

    michael Beta Tester

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Nicht, dass du dir was eingefangen hast? Läuft dein Virenscanner noch? bzw. aktualisiert er sich noch? Hast du mal einen Full System Scan gemacht? Hatte desletzt so ein Problem mit einem Fake-Antivirus. Der Virenscanner und einige Windows-Dienste wurden beendet und ließen sich nicht mehr starten.
     
  6. thl1966

    thl1966 Aktives Mitglied

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Genau das hatte ich bei einer Kundin. Zusätzlich ist der PC super langsam geworden. Ich musste den PC am Ende doch neu aufsetzen.
     
  7. homezonebenny

    homezonebenny Mitglied

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Also super langsam war er als alles im Windows 95 Stil war.
    Nachdem ich habe das beschriebene durchgeführt hatte lief wieder alles einwandfrei.
    Updates vom VirenScanner habe ich gemacht und geht auch. Full System Scan war das erste was ich gemacht hatte. Und er hat tatsächlich 4 Viren gefunden was mich sehr überrascht hat weil ich sehr Gründlich bin was das angeht (bin Programmierer von Beruf da ist Gründlichkeit wohl Pflicht).

    Momentan läuft alles super, normal wie immer schnell und maximal 30 Dienste beim Start (Maussoftware, also Logitech SetPoint und Taskmanager etc. dazu gezählt). Im Leerlauf sinds halt rund 30 Dienste. Das einzige was mich halt stark stört ist das ich "Defender" und "Driver Foundation" nicht anbekomme. Ich mein spürbar habe ich momentan kein Problem mit der Kiste, aber vlt. kennt ihr das wenn ihr wisst das etwas nicht stimmt dann beschäftigt das einen doch sehr und man will dies beheben.

    Ich kann momentan auch gar nicht sagen wie "schlimm" es ist wenn der Defender nicht mit läuft. Ich habe nur das Antivir Classic drauf das so weit ich weiß gegen Spyware etc. nicht schützt von daher wäre der Defender doch eig. notwendig. Aber was rede ich bei Windows über Sicherheit ^^ wenn ich mehr Sicherheit meiner Daten wollte würde ich sicherlich ein anderes System benutzen. Aber das ich großartig eigentlich eh nichts zu "verstecken" habe juckt mit das eig. herzlich wenig. Wichtig ist das die Gaming Kiste sauber läuft.
     
  8. homezonebenny

    homezonebenny Mitglied

    AW: Deaktivierte Dienste Starten nicht mehr?!

    Habe es über Registry Einträge lösen können.
    Man kann die Dienste ändern indem man den Starttyp in der Registry ändert.
    winTaste + r (Ausführen Fenster), "regedit" hineinschreiben und zu folgendem Pfad gehen:


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
    Jeder Ordner unter "Services" ist ein Windows Dienst. Klickt man einen Ordner an so sieht man rechts im Fenster einen "Start" (REG_DWORD) Typ. Doppelklickt man diesen so kann man in das PopUp-Fenster einen Wert hineinschreiben:

    1 = Automatisch verzögert
    2 = Automatisch
    3 = Manuell
    4 = Deaktiviert

    Den "Dienstnamen" kann man einfach im Dienste Fenster einsehen, indem man "Rechtsklick - Eigenschaften" auf einen Dienst macht. Dort sieht man dann den Dienstnamen der als Ordner in der Registry aufgelistet ist.


    Ich habe so alle Dienste die sich nicht aktivieren liesen wieder aktivieren können.
    Später habe ich über WIN + R (Ausführen Feld)
    msconfig
    ein paar Dienste deaktivieren wollen, und siehe da der gleiche Fehler wieder.
    Die haken liesen sich weder im MSCONFIG->Dienste setzen, noch über die Normale Dienste Oberfläche. Also musste ich WIEDER über die REGISTRY die Dienste einschalten.
    Das heißt irgendwie zerhaut "MSCONFIG->DIENSTE" irgendetwas wenn ich darüber fix ein paar Dienste einstellen möchte. Also stelle ich die Dienste jetzt nur noch über die dafür zur Verfügungstehende Oberfläche, also dem Dienste Fenster, dann klappts auch mit dem Nachbarn.


    Ich hoffe diese Information wird irgendwann jemandem helfen der ein ähnliches Problem mit dem einstellen der Dienste hat.
     
  9. michael

    michael Beta Tester

    AW: Deaktivierte Dienste lassen sich unter Windows 7 nicht mehr aktivieren

    Vielen Dank für die ausführliche Meldung. Ich habe den Thementitel mal so angepasst, dass das Thema vieleicht besser über Suchmaschinen gefunden wird. Ich denke mal, dass du bzw. dein PC kein Einzelfall ist ...
     
  10. homezonebenny

    homezonebenny Mitglied

    AW: Deaktivierte Dienste lassen sich unter Windows 7 nicht mehr aktivieren

    Ja, ich denke auch nicht das es ein Einzelfall ist.
    Es entstehen nur Fehler wenn man über:
    win + r -> msconfig -> Reiter "Dienste"
    Die Dienste verändert. Dann lassen diese sich weder über msconfig->Dienste noch über Systemsteuerung->Dienste wieder aktivieren (manche deakt. Dienste lassen sich aktivieren Defender etc. eben nicht...).

    Dies ist aber auch erst seit ner weile so, denn vor ein paar Windows Updates war dies eben nicht so. Vor rund 6 Monaten habe ich über msconfig->Dienste auch Einstellungen vorgenommen und da entstand kein Fehler. Jetzt lasse ich, zumindest am Desktop PC, msconfig->dienste in Ruhe und stelle Dienste nur noch über Systemsteuerung->Dienste ein.

    msconfig->Systemstart kann man aber getrost einstellen.
     
  11. saarman

    saarman Neuling

    AW: Deaktivierte Dienste lassen sich unter Windows 7 nicht mehr aktivieren

    Bei mir gabs das gleiche Problem. Irgendwann fiel mir ein, dass ich diese Dienste im abgesicherten Modus deaktiviert hatte.

    Also abgesicherten Modus gestartet, gewünschte Dienste wieder aktiviert und siehe da: nach einem Neustart war alles wieder in Butter. :D

    Gruß
     
  12. wwin

    wwin Neuling

    AW: Deaktivierte Dienste lassen sich unter Windows 7 nicht mehr aktivieren

    msconfig.exe Fehler: Vielen Dank für diese Anregung! Hat mein Problem mit einer nicht funktionierenden Bluetooth-Schnittstelle gelöst!

    Ich verwende Windows 7 mit ServicePack 1 und habe ebenfalls festgestellt, dass das Deaktivieren eines Dienstes mit msconfig.exe bewirkt, dass der entsprechende Registry-Eintrag in die Variable "Start" eine 4 (=disabled) geschrieben bekommt, die dann auf "natürliche" Weise nicht mehr zu entfernen ist. Hier hilft nur, diesen Registry-Eintrag händisch auf 3 (=manual) zu setzen. Zu Erinnerung: Mit regedit.exe - HKEY-LOCALMACHINE-SYSTEM-CurrentControlSet findet man eine alphabetisch geordnete Liste der Dienste und u.a. deren Variablen "Start" (1=automatisch-verzögert, 2=automatisch, 3=manuell, 4=deaktiviert).

    Start is a type REG_DWORD which specifies how the service is loaded or started. If the service is a Win32 service, the value of Start must be 2, 3, or 4. This value entry is not used for network adapters.

    Value D e s c r i p t i o n
    0 Boot: Loaded by kernel loader. Components of the driver stack for the boot (startup) volume must be loaded by the kernel loader.
    1 System: Loaded by I/O subsystem. Specifies that the driver is loaded at kernel initialization.
    2 Automatic: Loaded by Service Control Manager. Specifies that the service is loaded or started automatically.
    3 Manual:. The service does not start until the user starts it manually, such as by using Services or Devices in Control Panel.
    4 Disabled: Specifies that the service should not be started.

    Man kann dies am besten an einem erkenn- und zuordenbaren Namen testen, z.B. dem Dienst "Anwendungsidentität" = AppIDSvc. Deaktiviert man diesen mit msconfig.exe, so sieht man in der Registry, dass der Parameter "Start" in "AppIDSvc" zu 4 wird. Nun kriegt man mit msconfig das Häkchen erst dann wieder dauerhaft gesetzt, wenn man von Hand in der Registry bei AppIDSvc Start auf 3 setzt.

    Sollte jemand -wie ich - die Dummheit begehen, mit msconfig.exe alle Dienste zu deaktivieren, kann danach mit msconfig zwar die Nicht-Windows-Dienste wieder reaktivieren, nicht aber die Windowsdienste. Diese lassen sich dann aber - wie ich festgestellt habe -dadurch wieder reparieren (d.h. reaktivierbar machen), indem man die lange Liste der Dienste in der Registry nach Start = 4 durchforstet und durch Start = 3 ersetzt. (Aber bitte nicht überall 2 oder 1 einsetzen, sonst fährt das Windows evtl. nicht mehr hoch.) Anschließend können alle Dienste mit msconfig.exe wieder aktiviert werden und die Häkchen bleiben auch nach "Übernehmen" alle gesetzt. In Zukunft sollte man Dienste nur noch mit der Systemsteuerung aktivieren oder deaktivieren, solange Win7 diesen Bug hat.

    Ich hoffe, jemandem mit meinem Beitrag helfen zu können, wie auch die anderen Beiträge in diesem Thread mir geholfen haben.
    Viel Erfolg!
     
  • Werbung
  • Die Seite wird geladen...
    Hier genannte Produkt- und Firmennamen sowie deren Logos koennen eingetragene Warenzeichen der jeweiligen Unternehmen sein.